docker运行镜像抛异常:Unknown ABT_NODE_PACKAGE_NAME in environment: @abtnode/cli
docker run -p 10000 -v /tmp/docker-abtnode:/Users/data/arcblock --env ABT_NODE_DOMAIN=192.168.1.7 --env ABT_NODE_PORT=10000 arcblock/abtnode
返回错误信息:
WARNING: The requested image's platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested
⚠ @abtnode/cli is deprecated, please use @blocklet/cli by running following commands:
- npm uninstall -g @abtnode/cli
- npm install -g @blocklet/cli
abtnode start v1.6.1
ℹ Initialize new Blocklet Server instance config in /data/abtnode...
✖ Failed to initialize Blocklet Server configuration in /data/abtnode: ✖ Unknown ABT_NODE_PACKAGE_NAME in environment: @abtnode/cli
系统:mac os pro 2022 m2芯片
跑镜像应该不需要安装nodejs和abtnode/cli吧
6 条回复
另外docker镜像仓库(https://hub.docker.com/r/arcblock/abtnode)可以补充一些docker run 参数就更好了
抱歉给您带来麻烦。
出错的这个镜像已经被废弃了,您可以访问这里运行最新镜像: https://hub.docker.com/r/arcblock/blocklet-server
root@ecs-337447:/home/abt-node-1# sudo docker run -p 8001 -p 443 -v /home/abt-node-1:/data arcblock/blocklet-server
blocklet server v1.8.65
ℹ Initialize new Blocklet Server instance config in /data...
✖ Failed to initialize Blocklet Server configuration in /data: ✖ Failed to generate config EACCES: permission denied, mkdir '/data/.blocklet-server'
问题:宿主机本身是root权限,容器启动报权限问题
估计是要把原来的
.blocklet-server文件夹删除掉?调整了下命令行后可以正常运行: docker run -p 8001 -p 4431 -v /home/abt-node-1/:/data --privileged=true -u=root --name abt-node-1 arcblock/blocklet-server
Nice