跳到主要内容
ArcBlock Community

centos7 docker 镜像启动server异常,求助

you can
开发者
blocklet-serverbug-bountyqualifiedresolvedrewarded
javascript
ensureSystemSites failed: Error: could not open error log file: open() "/tmp/nginx-1731039079014/logs/error.log" failed (2: No such file or directory);251#251: the "user" directive makes sense only if the master process runs with super-user privileges, ignored in /tmp/nginx-1731039079014/nginx.conf:5;bind() to 0.0
.0.0:80 failed (13: Permission denied)                                                                                                                                                                                                                                                                                     
    at NginxProvider.validateConfig (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+router-provider@1.16.32_encoding@0.1.13/node_modules/@abtnode/router-provider/lib/nginx/index.js:307:13)                                                                                                                     
    at Router.validateConfig (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+core@1.16.32_@types+node@22.7.3_debug@4.3.7_encoding@0.1.13_sqlite3@5.1.7/node_modules/@abtnode/core/lib/router/index.js:162:25)                                                                                                    
    at RouterManager.validateRouterConfig (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+core@1.16.32_@types+node@22.7.3_debug@4.3.7_encoding@0.1.13_sqlite3@5.1.7/node_modules/@abtnode/core/lib/router/manager.js:674:24)                                                                                     
    at async RouterManager.addRoutingSite (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+core@1.16.32_@types+node@22.7.3_debug@4.3.7_encoding@0.1.13_sqlite3@5.1.7/node_modules/@abtnode/core/lib/router/manager.js:135:5)                                                                                      
    at async EventEmitter.ensureDashboardRouting (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+core@1.16.32_@types+node@22.7.3_debug@4.3.7_encoding@0.1.13_sqlite3@5.1.7/node_modules/@abtnode/core/lib/router/helper.js:878:25)                                                                               
    at async /home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+cli@1.16.32_@types+node@22.7.3_encoding@0.1.13/node_modules/@abtnode/cli/lib/commands/server/start.js:529:9                                                                                                                                          
✖ Blocklet Server start failed due to: Cannot read properties of undefined (reading 'domainAliases')                                                                                                                                                                                                                       
ℹ You can run blocklet server start again to fix error if it's router related.      

19 条回复

zhenqiang22个月前

使用的哪个镜像?

you can22个月前

arcblock/blocklet-server

zhenqiang22个月前

能发一下完整的启动命令吗?

you can22个月前

docker run -d --name blocklet --restart=always -p 8080 -p 4443 -v /arcblock:/data -v /arcblock/.arcblock:/home/arcblock/.arcblock --privileged arcblock/blocklet-server

zhenqiang22个月前

谢谢,我们尝试复现一下。

zhenqiang22个月前

/arcblock 目录在宿主机上存在吗?

you can22个月前

image.png

使用root用户登录进来的,宿主机存在这个目录,

尝试了下面两种挂载盘的启动:

docker run -d --name blocklet --restart=always -p 8080 -p 4443 -v /arcblock:/data --privileged arcblock/blocklet-server

docker run -d --name blocklet --restart=always -p 8080 -p 4443 -v /arcblock:/data -v /arcblock/.arcblock:/home/arcblock/.arcblock --privileged arcblock/blocklet-server

zhenqiang22个月前

我还不能确定是什么原因,你能先停止当前的容器,并尝试用这个命令启动下吗?然后给我一下这个命令启动后的截图: docker run --name blocklet -p 8080:80 -p 4443:443 arcblock/blocklet-server

you can22个月前

不挂在目录也报错

image.png

zhenqiang22个月前

在宿主机执行 uname -a 的结果是什么?

you can22个月前
javascriptCopy
Linux iZbp1cyybhwcd65a5u977gZ 3.10.0-1160.119.1.el7.x86_64 #1 SMP Tue Jun 4 14:43:51 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux  
zhenqiang22个月前(edited)

有可能和网络有关,你帮忙看下目前的 network 列表: docker network ls

如果有 bridge 模式,你试试用 bridge 模式启动一下: docker run --network bridge --name blocklet -p 8080:80 -p 4443:443 arcblock/blocklet-server

null22个月前

以前遇到权限问题过: docker跑arcblock/blocklet-server注意事项 docker run 后面加上这两个呢 --privileged=true -u=root

you can22个月前

不是这个

null22个月前

一样都是没权限,你那个报错

you can22个月前

这个是端口绑定失败。

null22个月前

🤔

image.png

zhenqiang22个月前

的确是容器内端口权限的问题,下个版本会包含修复。

zhenqiang22个月前(edited)

用户遇到的问题是因为镜像导致的,用户目前使用了一个修复的镜像,这个修复包含在下个版本。

回复