Skip to main content
ArcBlock Community

Unable to add DID Domain to Blocklet Server (self-hosted)

wgring
Developers
blocklet-serverclosedneed-context

Blocklet server 1.16.29, sqlite/canvas@next/npm/nvm/nginx all updated and current, node 21.6.2.

When trying to add a DID Domain to a self-hosted blocklet server, I am met with an error "Failed to issue certificate... ENOTFOUND..."

IP is accessible publicly (cellular tested, secure link is accessible)

53,80,443 forwarded to internal ip and enabled/allowed in Virtual Machine firewall (Ubuntu 22.04, UFW)

still receiving error when trying to establish did domain via typing method, error logs shows "failed to push notification to wallet"/"must be a valid uri"/"Validation error".

Attached screenshots of error and logs available:

Initial error during pages kit blocklet setup:

Screenshot_20240805_025550_Firefox.jpg

Blocklet Server log:

Screenshot_20240805_031536_Firefox.jpg

Screenshot_20240805_031549_Firefox.jpg

Screenshot_20240805_031558_Firefox.jpg

Blocklet Services log:

Screenshot_20240805_033056_Firefox.jpg

Service Gateway (nginx) log:

Screenshot_20240805_031747_Firefox.jpg

Screenshot_20240805_031756_Firefox.jpg

10 replies

zhenqiang2 years ago

I apologize for the inconvenience caused to you.

I think this is a known issue, and we have fixed it. Due to DNS caching, it takes time for the domain name to take effect; you may try to regenerate the certificate again.

wgring2 years ago

will check again in a few hours

wgring2 years ago

so far still the same, added enterprise spaces to attempt with the .rocks variant, different error message:

Screenshot_20240805_105304_Firefox.jpg

Screenshot_20240805_105634_Firefox.jpg

Screenshot_20240805_105751_Firefox.jpg

Screenshot_20240805_105759_Firefox.jpg

zhenqiang2 years ago

It's quite strange.

  1. Can you access http://calamari-cartel.did.life through your browser?
  2. I can't access http://72.207.178.84, so I suspect this address is not publicly accessible. If it's not publicly accessible, a certificate cannot be generated either.
wgring2 years ago
  1. Unable to access via domain, certificate couldnt generate
  2. the vm was off, try again.

the vm is publicly accessible via secure link

https://72-207-178-84.ip.abtnet.io/

zhenqiang2 years ago

I suspect it might be that the port 80 for the VM is inaccessible.

Please try accessing http://calamari-cartel.did.life again after opening port 80.

wgring2 years ago

Port 53, 80, and 443 are open, the internal ip for the vm is excluded from security detections as well.

the vm is accessible externally

Screenshot_20240805_190707_Firefox.jpg

Again, the domain didnt generate a certificate. No, it wont connect via domain. Yes it will connect via secure link provided via terminal

wgring2 years ago

link for the pages kit in question, also accessible via external network

https://bbqaqsycbscfvbv4o4iwz743ozlyzmusbrx7ssijegi.did.abtnet.io/en

this is the one that has enotfound error

zhenqiang2 years ago

Yes, port 443 is accessible.

And can you access https://calamari-cartel.did.life via HTTPS, although the domain does not have a certificate.

wgring2 years ago

ISP blocks 80 🙄

Reply