Skip to main content
ArcBlock Community

NFT Maker: Allowing Public Minting/DID Domains

wgring
Support
bugresolvedrewarded
  1. When toggling "Allow Public Minting Link", I receive an error referring to Domains:

"Cannot use the DID domain and IP echo domain to expose the casting link, please bind the domain name and recreate it." Image

Currently it, the DID domain/slp/IP echo domains are only the system-generated links that are input. "*did.abtnet.io" "*slp.abtnet.io" "*ip.abtnet.io"

The DID Domains I would like to connect with it eventually are not input on anything in this scenario, but they also do not end with ".abtnet.io". Is there a ".did" only domain/cert authority that is being implemented? All asterisks () denote wildcard assumptions.

  1. When attempting to add DID Domains onto the list, there is an error referring to certificate issuance:

"Failed to issue certificate for "xxxxx.did.yyyy" (x = domain choice, y = either of the available choices from DID Domains): DNS lookup failed: getaddrinfo ENOTFOUND "xxxxx.did.yyyy".

Image

Thanks again, I can still post the factory without the public mint link toggled, but I'd rather wait.

18 replies

Robert2 years ago(edited)

Anything *.abtnet.io is for developer internal use only, because we share HTTPS certificate across many of them, which means another developer have same certificate as yours, so it's possible (thought may not very valuable) to intercept encrypted messages since they have the exact same certificate.

For your own domain, no matter it's a DID secondary or TLD, the certificate is unique, only your server has that certificate, so it's more secure for your users.

Failed to issue certificate looks like a bug, the DNS is not correctly resolved.

Robert2 years ago

I talked to our team and know the reason why you hit this:

"Failed to issue certificate for "xxxxx.did.yyyy" (x = domain choice, y = either of the available choices from DID Domains): DNS lookup failed: getaddrinfo ENOTFOUND "xxxxx.did.yyyy".

because automatic NFT based domain is still in private beta, the blocklet server you are using may not support the auto-config through the new protocol. You manually entered the DNS so it's not possible to automatic config it.

We'll let you know when this is ready.

shijun2 years ago(edited)

z1croUysBVjGHD7KtHqZyhxKrCrSB2Z1Daa The DID Domain service is enabled on the official launcher, you can add your domain as follows

image.png

wgring2 years ago

tried getting to this from the notification link in email, sent me to the .cn site and i couldnt log in 😅

i will get on this now thanks

wgring2 years ago

worked like a charm, less than 10 seconds

wgring2 years ago

i seem to be missing one of the purchased domains and im fairly certain i didnt delete it 🤔 the .life shows fine, but the same name one with .rocks is missing

shijun2 years ago

multiple domains are maintained with multiple subscriptions and nfts, so they need to be added to your app separately.

What do you mean by saying "missing"? missing from did-wallet? from did-domain customer portal? or blocklet dashboard?

wgring2 years ago

missing from wallet, but shows under subscriptions

wgring2 years ago(edited)

still get the banner error of cannot use did domain and ip echo domain to expose casting link, please bind the domain name and recreate it.

Adding the domain itself seems to have not changed this part.

i upgraded the blocklets and also restarted all of them, again no change

Image

#2 is fixed 💪

shijun2 years ago

Maybe this can help, please remember to use your did-domain that attached to the app:

image.png

wgring2 years ago

yep this was my bad, forgot to change url section 😅

wgring2 years ago

does it take a while for the mint button to show in the factories section?

Image

wgring2 years ago(edited)

the mint seems to not be working properly? the images have the broken link thing

i may have had resolution too high, and with 10 multiplier. 😅 wont do that againImage

wgring2 years ago

all is good now with this post, everything resolved Image

wgring2 years ago(edited)

For the list of domains I have the DID Domain, and the three that were set up with the blocklet. of those three, if there were the ability to toggle off just the bottom one "ip(.)abtnet(.)io" without removing it from the list, would this solve the issue? 🤔 presuming the ip echo domain doesnt handle IPV6, 6to4, etcetera very well

wgring2 years ago(edited)

4to6 is what i meant. found it in log. Timed out.

is 464XLAT implemented?

Image

wgring2 years ago

no more 4tr6 timeouts

shijun2 years ago
Reply