Skip to main content
ArcBlock Community

Adding Domain To Blocklet

Vincent
Support
resolvedwont-fix

Hello ArcBlock team, I'm having trouble adding domains to my blocklets on a self hosted server. Below is the message I'm receiving after the certificate fails to be created. This happens with any domain I try to add to different blocklets. Same error in Chrome and Brave browsers.

Thank you!

"www.decentralbros.dev normally uses encryption to protect your information. When Brave tried to connect to www.decentralbros.dev this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be www.decentralbros.dev, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Brave stopped the connection before any data was exchanged.

You cannot visit www.decentralbros.dev right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later."

11 replies

wangshijun1 year ago
Vincent1 year ago(edited)

Thank you, but I am on the cloud, so not entirely self hosted. All ports are available as needed. I've never had this issue before and have tried more than one domain with different name servers.

zhenqiang1 year ago

I need your help to provide the following information:

  1. Is this domain bound to a Blocklet? Could you please send me a screenshot of the Blocklet domain list, similar to the one below

image.png

  1. Please send me the execution result of the commamnd blocklet server info. To ensure security, you can send it via private message.
Vincent1 year ago

No security concerns for dev, unless you think so. Thank you!

root@vmi2067561:~/blocklet-server-data# blocklet server info

blocklet server v1.16.32

ℹ Server DID zNKsyATu8nsvgW8rP3drLPyG6VcwKVr5qjY8

ℹ Server binary from: /root/.nvm/versions/node/v20.16.0/bin/blocklet

ℹ Server config from: /root/blocklet-server-data/.blocklet-server/config.yml

ℹ Server router provider: nginx

ℹ Server http port: 8080

ℹ Server https port: 443

ℹ Server host cpu: 4 / 4

ℹ Server host memory: 2.82 GiB / 5.80 GiB

ℹ Server host IP: {"internal":"154.38.191.121","external":"154.38.191.121","internalV6":"","externalV6":""}

ℹ Server DID zNKsyATu8nsvgW8rP3drLPyG6VcwKVr5qjY8

ℹ Server config from /root/blocklet-server-data/.blocklet-server/config.yml

ℹ Server file system isolation status: on(unavailable, version must be >= 21.6.0)

ℹ Docker enabled for running blocklets: off

ℹ Docker installed: off

ℹ Docker installation: You need to install Docker and ensure you have sufficient permissions to run it.

ℹ Server domain status: correct

System:

OS: Linux 5.15 Ubuntu 22.04.4 LTS 22.04.4 LTS (Jammy Jellyfish)

CPU: (4) x64 AMD EPYC 9224 24-Core Processor

Shell: 5.1.16 - /bin/bash

Binaries:

Node: 20.16.0 - ~/.nvm/versions/node/v20.16.0/bin/node

Yarn: 1.22.22 - ~/.nvm/versions/node/v20.16.0/bin/yarn

npm: 10.8.1 - ~/.nvm/versions/node/v20.16.0/bin/npm

Servers:

Nginx: 1.26.2 - /usr/sbin/nginx

npmGlobalPackages:

npm: 10.8.1

yarn: 1.22.22

root@vmi2067561:~/blocklet-server-data#

domains-screenshot1.png

wangshijun1 year ago

Hi, the screenshot above is from the server level domains, what does it look like of the blocklet you want to attach your domain to?

zhenqiang1 year ago

Did an error occur when clicking the ‘Generate Let's Encrypt Certificate’ button? If so, what was the error message?

image.png

Vincent23 months ago

Yes there still seems to be an issue when using generate certificate. This always worked before. Thank you.

zhenqiang23 months ago

What is the error message?

zhenqiang23 months ago

I understand now. I suspect it's because the Blocklet Server's 80 port is not accessible. Generating the certificate requires opening the 80 port.

image.png

Vincent23 months ago(edited)

image.png

Thank you! It's fixed now, I changed it to 80.

Vincent1 year ago

I'm using Cloudflare, but I'm not using any of their proxies or services. This issue happens with other DNS providers as well.

Reply