ensureSystemSites failed: Error: could not open error log file: open() "/tmp/nginx-1731039079014/logs/error.log" failed (2: No such file or directory);251#251: the "user" directive makes sense only if the master process runs with super-user privileges, ignored in /tmp/nginx-1731039079014/nginx.conf:5;bind() to 0.0
.0.0:80 failed (13: Permission denied)
at NginxProvider.validateConfig (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+router-provider@1.16.32_encoding@0.1.13/node_modules/@abtnode/router-provider/lib/nginx/index.js:307:13)
at Router.validateConfig (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+core@1.16.32_@types+node@22.7.3_debug@4.3.7_encoding@0.1.13_sqlite3@5.1.7/node_modules/@abtnode/core/lib/router/index.js:162:25)
at RouterManager.validateRouterConfig (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+core@1.16.32_@types+node@22.7.3_debug@4.3.7_encoding@0.1.13_sqlite3@5.1.7/node_modules/@abtnode/core/lib/router/manager.js:674:24)
at async RouterManager.addRoutingSite (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+core@1.16.32_@types+node@22.7.3_debug@4.3.7_encoding@0.1.13_sqlite3@5.1.7/node_modules/@abtnode/core/lib/router/manager.js:135:5)
at async EventEmitter.ensureDashboardRouting (/home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+core@1.16.32_@types+node@22.7.3_debug@4.3.7_encoding@0.1.13_sqlite3@5.1.7/node_modules/@abtnode/core/lib/router/helper.js:878:25)
at async /home/arcblock/.local/share/pnpm/global/5/.pnpm/@abtnode+cli@1.16.32_@types+node@22.7.3_encoding@0.1.13/node_modules/@abtnode/cli/lib/commands/server/start.js:529:9
✖ Blocklet Server start failed due to: Cannot read properties of undefined (reading 'domainAliases')
ℹ You can run blocklet server start again to fix error if it's router related.
19 replies
使用的哪个镜像?
arcblock/blocklet-server
能发一下完整的启动命令吗?
docker run -d --name blocklet --restart=always -p 8080 -p 4443 -v /arcblock:/data -v /arcblock/.arcblock:/home/arcblock/.arcblock --privileged arcblock/blocklet-server
谢谢,我们尝试复现一下。
/arcblock目录在宿主机上存在吗?使用root用户登录进来的,宿主机存在这个目录,
尝试了下面两种挂载盘的启动:
docker run -d --name blocklet --restart=always -p 8080 -p 4443 -v /arcblock:/data --privileged arcblock/blocklet-server
docker run -d --name blocklet --restart=always -p 8080 -p 4443 -v /arcblock:/data -v /arcblock/.arcblock:/home/arcblock/.arcblock --privileged arcblock/blocklet-server
我还不能确定是什么原因,你能先停止当前的容器,并尝试用这个命令启动下吗?然后给我一下这个命令启动后的截图:
docker run --name blocklet -p 8080:80 -p 4443:443 arcblock/blocklet-server不挂在目录也报错
在宿主机执行
uname -a的结果是什么?有可能和网络有关,你帮忙看下目前的 network 列表:
docker network ls如果有
bridge模式,你试试用 bridge 模式启动一下:docker run --network bridge --name blocklet -p 8080:80 -p 4443:443 arcblock/blocklet-server以前遇到权限问题过: docker跑arcblock/blocklet-server注意事项 docker run 后面加上这两个呢 --privileged=true -u=root
不是这个
一样都是没权限,你那个报错
这个是端口绑定失败。
🤔
的确是容器内端口权限的问题,下个版本会包含修复。
用户遇到的问题是因为镜像导致的,用户目前使用了一个修复的镜像,这个修复包含在下个版本。